• Advertisement

Archived

This topic is now archived and is closed to further replies.

Demo available

This topic is 6007 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

The demo discussed in the "Beta 9" thread has been made available. Unfortunately, @Home apparently has disabled port 80, so I have moved my web site to port 8000. We''ll see how long it takes them to find that! I''ve got two versions, one with and one without the data. Alliance_Source_001 has no data, and is 82.5K Alliance_Full_001 has all the data (as well as the source), and is 21.9M BugslayerUtil is 77.4K and is only needed if you want to compile the demo. The executable is included in the full version only, since the data is required to run it. http://www.thoughtwaves.com:8000/PowerRender4/Alliance_Source_001.zip http://www.thoughtwaves.com:8000/PowerRender4/Alliance_Full_001.zip http://www.thoughtwaves.com:8000/PowerRender4/BugslayerUtil.zip Misquoting the other thread: The demo includes a loose quadtree, C++ usage, nice character movement (walking/following), and a sort of Diablo-like camera control. All of these (except the C++ part) are unfinished. Be sure to read the readme.txt for instructions! I''ll be out of town until 9/15, so any questions/problems will have to wait until then. Dave

Share this post


Link to post
Share on other sites
Advertisement
I can''t run it. I get the error that I''m missing the file "stlport_vc6_debug.dll". I searched my HD and I don''t have that file anywhere. Where are we supposed to get this file?

-Rich

Share this post


Link to post
Share on other sites
Oops, forgot that. You can find it now at:

http://www.thoughtwaves.com:8000/PowerRender4/stlport_vc6_debug.dll

Share this post


Link to post
Share on other sites
Which reminds me, I used STLPort instead of the built-in Dinkum version. I''m not sure what issues you''ll run into if you don''t use STLPort.

Share this post


Link to post
Share on other sites
I get a Bugslayerutil.dll linked to missing export imagehlp.dll:SymGetLineFromAddr



Gary

Share this post


Link to post
Share on other sites
That''s strange. I thought that was a Windows DLL. Oh well.
I have them available at:

http://www.thoughtwaves.com:8000/PowerRender4/IMAGEHLP_98.DLL
http://www.thoughtwaves.com:8000/PowerRender4/IMAGEHLP_2000.DLL

Download the appropriate one for 98 or 2000 and rename it. They are in my system (for 98) and system32 (for 2000) directories, so you may need to put them there also.

If you get a chance to try it tonight, do it quickly. It''s off to bed soon for me and I leave at 6am tomorrow.

Share this post


Link to post
Share on other sites
Ok, one more thing. My DNS provider''s application is returning errors, so I don''t know if they''re going down or what. If you can''t resolve thoughtwaves.com, the IP is 65.15.120.26.

Share this post


Link to post
Share on other sites
Well... The thing is that my windows has the dll already. The error message says the missing export is imagehlp.dll:SymGetLineFromAddr which means it found the dll just not the SymGetLineFromAddr.

But, I tried your dlls anyway and got the same result.


Gary

Share this post


Link to post
Share on other sites
Well, I don''t have time to figure it out right now. All I can suggest is to go to the Microsoft web site and search for BugslayerUtil. It''s in the Microsoft Journal area. There''s an article there that describes its use and installation. I seem to recall a seperate zip file with other dll''s in it, but I didn''t need it. Maybe you do?

Share this post


Link to post
Share on other sites

  • Advertisement