Sign in to follow this  
hserver

simple texture filtering problem

Recommended Posts

hserver    142
Hi everyone
take a look at my attachs the first one is a shot form our game in a test pc the second file is in my own pc what works fine
any idea what is wrong?

Share this post


Link to post
Share on other sites
Adam_42    3629
The one on the left looks to me like it's picking the wrong texture mipmap level, or possibly a smaller texture.

Do you do anything with D3DSAMP_MIPMAPLODBIAS when rendering it?

Share this post


Link to post
Share on other sites
Matias Goldberg    9582
Your PC supports Anisotropic filtering, while the test one doesn't

Another option, you're letting mipmaps to be automatically generated, and it's broken on the test PC's drivers. Update the drivers or use DDS to generate mipmaps manually and easily.




It's going to help a lot if you publish the specs from both machines (including driver versions).

Share this post


Link to post
Share on other sites
hserver    142
[quote name='Adam_42' timestamp='1303058600' post='4799506']
The one on the left looks to me like it's picking the wrong texture mipmap level, or possibly a smaller texture.

Do you do anything with D3DSAMP_MIPMAPLODBIAS when rendering it?
[/quote]

I check it out and now pretty sure I didn't do anythings with MIPMAPLODBIAS
And of course The testures are the same in both PC
Anyway thanks for your suggestions

Share this post


Link to post
Share on other sites
hserver    142
[quote name='Matias Goldberg' timestamp='1303059471' post='4799510']
Your PC supports Anisotropic filtering, while the test one doesn't

Another option, you're letting mipmaps to be automatically generated, and it's broken on the test PC's drivers. Update the drivers or use DDS to generate mipmaps manually and easily.




It's going to help a lot if you publish the specs from both machines (including driver versions).


[/quote]
Nice Suggestions
My own pc have GeForce 8500 and video card of test pc is GeForce6200
In both pc D3DPTFILTERCAPS are the same and shown in the shot using dx caps viewer
Is It Possible That DxCapsViewer show a wrong capacity? ( in Anisotropic filtering)

Share this post


Link to post
Share on other sites
Matias Goldberg    9582
[quote name='hserver' timestamp='1303114068' post='4799802']
Nice Suggestions
My own pc have GeForce 8500 and video card of test pc is GeForce6200
In both pc D3DPTFILTERCAPS are the same and shown in the shot using dx caps viewer
Is It Possible That DxCapsViewer show a wrong capacity? ( in Anisotropic filtering)
[/quote]
No. Dx Caps Viewer works fine. However, there was an (somewhat old) nvidia's driver version which broke mipmap generation, so that could be it. Other possibilities could include using uninitialized variables, therefore you end up (by accident) with anisotropic filtering in one machine, and bilinear filtering in the other one.

Also look your Driver config. NVIDIA config has the option to override anisotropic filtering. Make sure it isn't turned off. On the other hand, if your driver config is set to "Best Performance" instead of "Quality" or "Best Quality" you'll end up with those results you're seeing.

Share this post


Link to post
Share on other sites
hserver    142
[quote]Also look your Driver config. NVIDIA config has the option to override anisotropic filtering. Make sure it isn't turned off. On the other hand, if your driver config is set to "Best Performance" instead of "Quality" or "Best Quality" you'll end up with those results you're seeing.[/quote]

Bingo!
That's it.
On that test pc nvidia cpanel there is an option "anisotropic-mip optimization" which is (By default) turned off.
Thanks a lot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this