Jump to content
  • Advertisement
Sign in to follow this  
spikaa

Deploying XNA program using Visual Studio Installer

This topic is 2762 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi. I made a simple XNA program with about 20 png images in the content pipeline program, and it runs fine in Visual Studios.

The problem is when I run the .EXE file, which the .msi installer (created using Visual Studios Installer) created after installation.

I attached a couple of screenshots of my situation. Notice on the 2nd screenshot the 20 png images are not found in the Application Folder, even though I have configured the installer to include it. :(

Please help I really have no clue about this anymore. I have 2 different ebooks on XNA, but none of them tells me how to deploy a game...

Share this post


Link to post
Share on other sites
Advertisement

did you install the XNA runtime ?
i had that problem when i was trying that out. it is on the XNA site or you could google for it
:)


Yes I already had it installed. Maybe it wasn't included in the installer? How do I include it in the installer?

It's also possible that the problem is entirely different...

Share this post


Link to post
Share on other sites
I still need help on this...

Right now, the way I test my game is through OneClick Installer. TBH I don't really like how it installs my game. It's not how typical programs are installed...

Share this post


Link to post
Share on other sites

[quote name='ryan20fun' timestamp='1305270281' post='4810101']
did you install the XNA runtime ?
i had that problem when i was trying that out. it is on the XNA site or you could google for it
:)


Yes I already had it installed. Maybe it wasn't included in the installer? How do I include it in the installer?

It's also possible that the problem is entirely different...
[/quote]
sorry about that, i was very much so preocupioed with the GameDev.net Community Challenge(5 seconds of being smart cost me atleast 5 hours of pain)
i last used the VS instal project about 2 years ago(briefly to see what it is about) and i remember there being a dependicy's tab or something in the projects settings or in solution explorer, im going to try makeing a VS install project and see how to do it :)

Share this post


Link to post
Share on other sites
oh, i just noticed ive got a install shield project type and then some VS project types, which one do you want ?
il try the install shield first then maybe the others

---edit---
i cant use the install shield one as i have to download and register or something for it.
so the VS one will do

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!