Sign in to follow this  

UDK Beginners Tutorial Error Help

This topic is 2344 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi All.

Sorry if this is the wrong forum, but i thought it would be the best place to post it.

i am busy trying out the UDK ( UDK-2009-11 )

Getting error while following a UDN getting started tutorial.

here is the output from Unreal Frontend
[code]
[COMMANDLET 'UDK.exe make' STARTED IN ''] July 11, 7:32 PM

Init: Version: 5860
Init: Epic Internal: 0
Init: Compiled (32-bit): Oct 30 2009 13:16:54
Init: Command line: -DEFENGINEINI=..\..\UTGame\Config\DefaultEngineUDK.ini
Init: Base directory: C:\UDK\UDK-2009-11\Binaries\Win32\
Init: Character set: Unicode
Log: Executing Class UnrealEd.MakeCommandlet
--------------------Core - Release--------------------
--------------------Engine - Release--------------------
--------------------GameFramework - Release--------------------
--------------------UnrealEd - Release--------------------
--------------------UnrealScriptTest - Release--------------------
--------------------IpDrv - Release--------------------
--------------------OnlineSubsystemPC - Release--------------------
--------------------UTGame - Release--------------------
--------------------UTEditor - Release--------------------
--------------------UTGameContent - Release--------------------
--------------------UDNGame - Release--------------------
Analyzing...
Error, Superclass FrameworkGame of class UDNGame not found
Error, Superclass MobileHUD of class UDNHUD not found
Compile aborted due to errors.

Warning/Error Summary
---------------------
Error, Superclass FrameworkGame of class UDNGame not found
Error, Superclass MobileHUD of class UDNHUD not found

Failure - 2 error(s), 0 warning(s)
Execution of commandlet took: 7.96 seconds

[COMMANDLET 'UDK.exe make' FAILED] July 11, 7:32 PM
[/code]

here are the two files that are giving the problem

UDNGame.uc
[code]
class UDNGame extends FrameworkGame;

defaultproperties
{
PlayerControllerClass=class'UDNGame.UDNPlayerController'
DefaultPawnClass=class'UDNGame.UDNPawn'
HUDType=class'UDNGame.UDNHUD'
bDelayedStart=false
}
[/code]

UDNHUD.uc
[code]
class UDNHUD extends MobileHUD;

defaultproperties
{
}DelayedStart=false
}
[/code]

here is the [UnrealEd.EditorEngine] section of DefaultEngine.ini
[code]
[UnrealEd.EditorEngine]
EditPackagesOutPath=..\..\UTGame\Script
FRScriptOutputPath=..\..\UTGame\ScriptFinalRelease
+EditPackages=OnlineSubsystemLive
+EditPackages=OnlineSubsystemPC
+EditPackages=UTGame
+EditPackages=UTEditor
+EditPackages=UTGameContent
+EditPackages=UDNGame
;ModEditPackages=MyMod
AutoSaveDir=..\..\UTGame\Autosaves
InEditorGameURLOptions=?quickstart=1?numplay=1
[/code]

so, anybody know what is wrong ?

---extra---
[url="http://dl.dropbox.com/u/30790443/UDNGame.rar"]Link to the files i made from the tutorial[/url]

---edit---
[url="http://udn.epicgames.com/Three/BasicGameQuickStart.html"]here is the tutorial[/url]

Share this post


Link to post
Share on other sites
Why are you using such a critically outdated version of UDK? There was a new release in June from [url="http://www.udk.com"]www.udk.com[/url] .

It seems like your install of UDK is messed up, I would try uninstalling it and doing a clean reinstall with the latest build.

EDIT: Actually the problem is that the classes simply did not exist in the 2009 build. Seriously, download the latest version and it will fix your problems. What do you expect when you follow a tutorial updated in January of 2011 and your trying to use a build from 2 years ago?

Share this post


Link to post
Share on other sites
[quote name='shadowisadog' timestamp='1310440953' post='4834113']
Why are you using such a critically outdated version of UDK? There was a new release in June from [url="http://www.udk.com/"]www.udk.com[/url] .

It seems like your install of UDK is messed up, I would try uninstalling it and doing a clean reinstall with the latest build.

EDIT: Actually the problem is that the classes simply did not exist in the 2009 build. Seriously, download the latest version and it will fix your problems. What do you expect when you follow a tutorial updated in January of 2011 and your trying to use a build from 2 years ago?
[/quote]

ok, Thanks.
the reason i was using it was because i got it from a friend a while ago and thought i would try it out.
and yes im working on getting the new version(slow ISP speed)

Share this post


Link to post
Share on other sites

This topic is 2344 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this