Sign in to follow this  
DriveByBaptism

OpenCL AMD Environment Set Up.

Recommended Posts

DriveByBaptism    122
[font=Verdana, Arial, Helvetica, sans-serif][size=2][font=Verdana, Arial, Helvetica, sans-serif][size=2]I am trying to learn OpenCL, but I am having some real problems setting up my environment. I have spent the last 2 hours following links and so called guides on how to run my first OpenCL program.

I have update my graphics card drivers to make sure it supports OpenCL (my card is a msi radeon x1550 and I have a really old computer in case you couldn't tell), I downloaded the AMD APP SDK and followed its instructions on how to build/run the first program. But when I do I get the following error:

Note it is the simple "hello world" app that comes with it.

fatal error C1083: Cannot open include file: 'CL/opencl.h'
fatal error C1083: Cannot open include file: 'SDKFile.hpp'

I am using Visual Studio Express 2010 and I just ran the program as it came. I haven't touched a line of code or messed with any of the programs hierarchy. Going by the files instructions, it really should have been a case of hit F5 and go. But I keep getting the above errors.

I even bought the OpenCL PDF to work through but it doesn't cover set up of AMD. They have a nice bit about everything else, just not AMD. [/size][/font]

[font=Verdana, Arial, Helvetica, sans-serif][size=2] [/size][/font]

[font=Verdana, Arial, Helvetica, sans-serif][size=2]I can run the precompiled programs that come with the AMD APPS SDK but I can't run the code from inside Visual Studio Express. I have both 2008 and 2010 and both have the same problems.[/size][/font]

[/size][/font]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this