Jump to content
  • Advertisement
Sign in to follow this  
Yours3!f

how to disable mip-mapping?

This topic is 2500 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi,

I've enabled anisotropic filtering in my app, and for some reason mip-mapping got enabled as well, despite I didn't enable it.

I enabled anisotropic filtering like this:

dx_dev->SetSamplerState(0, D3DSAMP_MAGFILTER, D3DTEXF_ANISOTROPIC);
dx_dev->SetSamplerState(0, D3DSAMP_MINFILTER, D3DTEXF_ANISOTROPIC);

D3DCAPS9 caps;
dx_dev->GetDeviceCaps(&caps);
dx_dev->SetSamplerState(0, D3DSAMP_MAXANISOTROPY, caps.MaxAnisotropy);


How can I explicitly order the API to disable mip-mapping?

Best regards,
Yours3!f

Share this post


Link to post
Share on other sites
Advertisement
Using anisotropic filtering implies you want mip mapping. Anisotropic filtering requires mip maps to work

Share this post


Link to post
Share on other sites

Using anisotropic filtering implies you want mip mapping. Anisotropic filtering requires mip maps to work


Ok, you're right...

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!