Jump to content
  • Advertisement
Sign in to follow this  
doomtoo

Blending "stitch" marks on edges of textures?

This topic is 2554 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

texture_problem.jpg

I have two+ different textures being rendered onto of other ones, but they don't "blend" correctly, and put in 1-2px "stitch marks" at the edges of the texture.

I tried putting them together from their loaded files in Photoshop, and the dark edges aren't there, so it has to be something between loading the textures, or displaying them.

Even moving parts to completely on top of other parts, they still show dark edges (such as the shoulder and the neck area above).

Are there any blending options I could change to allow it to blend edges better, or something else that would need to be changed?

Thanks!

Share this post


Link to post
Share on other sites
Advertisement

texture_problem.jpg

I have two+ different textures being rendered onto of other ones, but they don't "blend" correctly, and put in 1-2px "stitch marks" at the edges of the texture.

I tried putting them together from their loaded files in Photoshop, and the dark edges aren't there, so it has to be something between loading the textures, or displaying them.

Even moving parts to completely on top of other parts, they still show dark edges (such as the shoulder and the neck area above).

Are there any blending options I could change to allow it to blend edges better, or something else that would need to be changed?

Thanks!


I don't believe you have a problem with "blending" per see. What usually happens in these cases is that you forget to offset your uv by half a textel. I.e. say the uv's are 0-1 and the texture is 0-255 (i.e. 256 wide/high). When you map the UV's, 0 does not equal 0 in this case. You want the center of the textel to be mapped to 0,0 which in this case is not 0=0 as 0 in the case of the texture means the "edge" of the textel and not the center. So, the edge u or v should actually be set to, assuming u: u=1/256 (or maybe 255, always forget). Without the offset you blend to black at the edges. Or, you blend to the other side of the texture which means you blend to an incorrect color which will make the seam visible also.

hope this helps, if you need more information, let me know.

Share this post


Link to post
Share on other sites
is your model one mesh or is the head separate from the body etc? if the are separate then your normals may not align at the boundaries.

otherwise it is a texture issue. as mentioned above if your texture image size is exactly the same size as your model you may be wrapping around the edges or clamping the black. try this... scale the texture down a little so that you can extend the boundary colors a few pixels each way in your file without increasing the number of pixels you have. the also scale your uv mapping to match your new texture and that should fix the problem.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!