Sign in to follow this  
nano511

cannot start project?

Recommended Posts

nano511    103
Im am using msvc 2010 express and when i tried to compile it said something like "cannot start project". I tried it again, and now it says i have a LNK error:
[code]

1>LINK : fatal error LNK1168: cannot open C:\Users\david\Documents\Visual Studio 2010\Projects\MyGame\Debug\MyGame.exe for writing
[/code]

what could be causing this?

Share this post


Link to post
Share on other sites
Radikalizm    4807
MyGame.exe is probably still running in the background, or it is being used by another application (or you made the file read-only somehow); make sure the file can be written to and try again

Share this post


Link to post
Share on other sites
nano511    103
Okay i fixed that but now im getting
[code]

1>TRACKER : error TRK0002: Failed to execute command:
""c:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\bin\CL.exe" @C:\Users\david\AppData\Local\Temp\c7d36f5459f94dc794575b38c8d51a07.rsp". Access is denied.

[/code]

Share this post


Link to post
Share on other sites
frob    44904
[quote name='nano511' timestamp='1312842505' post='4846411']
TRACKER : error TRK0002: Failed to execute command:
[/quote]


Google is your friend. [url="http://www.google.com/search?q=TRACKER+:+error+TRK0002:+Failed+to+execute+command"]Searching for those words quoted above[/url] gives me a very promising list of results.

Based on those results, it looks like you specified your program should run only on Win64 configurations. Either that, or you have corrupted your system to mix 32-bit and 64-bit settings.

If the first is true, you should rebuild your project to target "any cpu", or target Win32, or follow the instructions in several of the linked answers that explain how to mark your program as compatible with the 64-bit OS.


Building for 64-bit only is generally a bad thing, unless you plan on releasing multiple copies of your executable.

Since this is a For Beginners post, I'm guessing that isn't the case. That is something you would do if you were developing applications that require >3GB main memory, or have been hand-optimized with 64-bit assembly code, or otherwise have an absolute performance requirement for the 64-bit extensions. It is not something a beginner is likely to do.


Build your game to run as a 32bit windows app.

Share this post


Link to post
Share on other sites
nano511    103
I looked at like the first 6 links and i cant find how to fix it. All i did was change ' = 50' to '+= 50' and everything started getting messed up lol

E: found the problem. i accidentally wrote 'xVel = =50;'

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this