Jump to content
  • Advertisement
Sign in to follow this  
altich88

OpenGL OpenGL is running software mode... it shouldn't be!

This topic is 2528 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi,

I've recently bought an SSD and re-installed windows onto it. I installed all my drivers as usual and everything seemed to be ok. When I loaded up my current game project in visual studio it ran extremely slowly.

A call to glGetString(GL_VENDOR) returned "Microsoft Corporation" - does this mean my game is running in software mode and hence the terrible performance?

I've installed my graphics drivers as usual (been using the same version for ages) and all other commercial games etc. seem to be running just as well as before.

Why would OpenGL not use the installed ATI drivers like it did before?

Thanks for your help.

Share this post


Link to post
Share on other sites
Advertisement
There is an app for that
http://www.opengl.org/wiki/GlGetString



glGetString(GL_VENDOR)
This returns the company name of whoever wrote the GL driver. It could be "ATI Technologies", "NVIDIA Corporation", "INTEL" and so on. Note that there's no guarantee that the string for a specific vendor will remain the same in future implementations. On Windows, if it says "Microsoft" then you are using the Windows software renderer or the Windows Direct3D wrapper. You probably haven't installed the graphics drivers yet in that case.
[/quote]

If it isn't working, then it could be that there is something wrong with the registry. Contact ATI and let them know there is a problem with their driver install.

Share this post


Link to post
Share on other sites
Thanks for the fast reply.

Yes it was an issue with the driver installation by the looks of it, seemed to run commercial games ok but not my own.

There seemed to be a problem with the windows-found ATI drivers, so I used a registry cleaner to clear the old ATI references etc.

I tried the newest package from ATI and all seems to be well.

Thanks again!

Share this post


Link to post
Share on other sites

There seemed to be a problem with the windows-found ATI drivers


Windows always installs a default 2D only VGA driver. That is the cause of your problems. If you actually install the ATI drivers (which it looks like you have now), you'll actually get 3D support ;)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!