Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

cha Mithrandir

D3D8 Alpha-Transparency

This topic is 6093 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have tried to add alpha-transparency to my textures (I use 32-bit tga, like Quake3 does) and in another project the code worked well. But in the other project I''m currently working on the textures suddently were "solid", no sign of transparency. At first I thought I had forgotten to do this line:
m_pd3dDevice->SetRenderState( D3DRS_ALPHABLENDENABLE,   TRUE ); 
But I looked it up, it was were I had intended it. Then I started to check if my device was HAL and so on, but everything was fine. At last I found out, that my
m_pd3dDevice->SetRenderState( D3DRS_ALPHABLENDENABLE,   TRUE ); 
was inside the
m_pd3dDevice->BeginScene(); 
Then I put it right after the device creation code it works fine. But I wonder if I made some mistake or if it was just bad luck. Has anyone experienced similar problems? BTW: It works fine now, after 3 hours oder frustation and cursing.

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!