• Advertisement

Archived

This topic is now archived and is closed to further replies.

AH, BOOK DOESNT WORK!

This topic is 5993 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I just bought the OpenGL game programming book and the damn thing won''t let me compile. I can compile the files but can''t make the .exe, it says that the linking process doesn''t know where to go. I installed the SDKs and I put them together with MSVC++. It still won''t work. I have done everything the book has told me to do. Please don''t tell me what the book says, it won''t work.

Share this post


Link to post
Share on other sites
Advertisement
You neeed to go to (in your MSVC++ compiler) Project->Add Files-> And add the OpenGL library files. Glu32.lib,Glaux.lib, OpneGL32.lib.

It tells you somewhere in the first or second chapter Im trying to find the page for you, I had the same problem and I read the chapter and found the solution(after posting and asking for help with the problem, I am too stubborn to believe I missed it so I went and checked for myself...)

"I've sparred with creatures from the nine hells themselves... I barely plan on breaking a sweat here, today."~Drizzt Do'Urden

Edited by - Drizzt DoUrden on September 21, 2001 10:36:28 PM

Edited by - Drizzt DoUrden on September 21, 2001 10:39:34 PM

Share this post


Link to post
Share on other sites
Page 8 and 9 of the book have it all.

BTW, this is THE most commonly asked question and problem Dave and I have received. If I write another GL book, I''ll probably end up reminding people for the first half of the book on every example that they need to link the libraries.

Kevin

Share this post


Link to post
Share on other sites
I said I already did this, its still not working, yes I declare the use of the .lib everytime I (try to) write a program too.

Share this post


Link to post
Share on other sites
Never mind, got it fixed. I had extracted the files to the right directories but the automaticly made subdirectories. I had named the files in VC++ wrong, so I had to configure my options again. Now it works fine though!

Share this post


Link to post
Share on other sites
Hmmm... Too late... Doh!



"And that's the bottom line cause I said so!"

Cyberdrek
Headhunter Soft
A division of DLC Multimedia

Resist Windows XP's Invasive Production Activation Technology!

"gitty up" -- Kramer

Edited by - Cyberdrek on September 24, 2001 4:59:07 PM

Share this post


Link to post
Share on other sites

  • Advertisement