Jump to content
  • Advertisement
Sign in to follow this  
jamesleighe

DebugBreak () Access Violation?

This topic is 2649 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

(MSVC 2010 Ult, C++, Win7)

I use DebugBreak to break into running applications (by waiting for the "Test.exe has stopped working" message and using "Debug the program" and selecting the environment.)

However, ever since I reinstalled everything on my development box I can't resume the process! It it first give me "Unhandled exception at 0x77a015ee in Test.exe: 0xC0000005: Access violation." then repeats "Unhandled exception at 0x77a015ee in Test.exe: 0x00000000: The operation completed successfully." forever!

What the heck is going on here?
It works on my old dev box, and other coworkers boxes but not mine.

Share this post


Link to post
Share on other sites
Advertisement
You could make it pop up a message box really early, to pause the application and give you time to attach the debugger.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!