Sign in to follow this  
schupf

Is there a name for: Position + Orientation

Recommended Posts

Hello,

my scene objects all have a position, scale and orientation. I want to write a getter method that returns true,
if any of these 3 attribues has been modified (compared to the last frame):

[code]
SceneObject* obj = ...
bool b = obj->isPositionOrRotationOrScaleDirty(); // Need a better name for this method
// b = false
obj->setRotation(45);
b = obj->isPos...
// b = true
[/code]

The stupid problem: I can't think of any good name. Is there a general word for position/scale/rotation?

Share this post


Link to post
Share on other sites
One of the dictionary definitions of "situation" means position and orientation; however, this is not one of the common modern usages of the word. The verb form "situate" is less ambiguous for that purpose.

Share this post


Link to post
Share on other sites
Hidden
A relatively sane name for a pos+quat would be 'rotor' (google rotors and geometric algebra). Otherwise I'd stick with PosQuat (my personal preference). Using 'transform' implies that the PosQuat supports translation, rotation, scaling, shearing and reflection. Which it doesn't.
[size="2"] [/size]

Share this post


Link to post
Quite honestly, its whatever works for you/whatever you want it to be. If you are working with colleagues, just have it documented so that they know what exactly it is.

Abbreviation always works to. But, again, document. Even for yourself. Once your code amounts to 100,000 lines and your looking for what that one function does, you'll wish you documented.

Share this post


Link to post
Share on other sites
Thanks for your suggestions! I will use "transform", since its both short and accurate.

And yes, I document a lot. I had too many frustrating moments in the past, where I did not understand my own code :D

Share this post


Link to post
Share on other sites
[quote name='schupf' timestamp='1317657137' post='4868587']
Hello,

my scene objects all have a position, scale and orientation. I want to write a getter method that returns true,
if any of these 3 attribues has been modified (compared to the last frame):[/quote]
Then what you want is a dirty flag.
An appropriate name would be:
TransformIsDirty()
TransIsDirty()
IsDirty()

Something along these lines.

Just a note, they are frequently called position (or translation), rotation, and scale.
Orientation typically represents all of them together, to get the final orientation of the object in space.
The transform matrix is then built directly off this.

As mentioned you can go whichever way you like, but this is one common way.


L. Spiro

Share this post


Link to post
Share on other sites
You might be thinking of an Affine Transform
[url="http://en.wikipedia.org/wiki/Affine_transformation"]http://en.wikipedia.org/wiki/Affine_transformation[/url]

Mostly I just call it a Position though, AffineTransformation is unwieldy.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this