Is there a name for: Position + Orientation

Started by
10 comments, last by speciesUnknown 12 years, 6 months ago
Hello,

my scene objects all have a position, scale and orientation. I want to write a getter method that returns true,
if any of these 3 attribues has been modified (compared to the last frame):


SceneObject* obj = ...
bool b = obj->isPositionOrRotationOrScaleDirty(); // Need a better name for this method
// b = false
obj->setRotation(45);
b = obj->isPos...
// b = true


The stupid problem: I can't think of any good name. Is there a general word for position/scale/rotation?
Advertisement
Transformation, and if matrices are involved, transformation matrix. So getTransform() or getTransformation() would make sense.
"When you die, if you get a choice between going to regular heaven or pie heaven, choose pie heaven. It might be a trick, but if it's not, mmmmmmm, boy."
How to Ask Questions the Smart Way.
Considering that these things are usually stored or at least end up in a transformation matrix each frame...

edit: I need to start refreshing before replying...
f@dzhttp://festini.device-zero.de
Transform

Stefano Casillo
TWITTER: [twitter]KunosStefano[/twitter]
AssettoCorsa - netKar PRO - Kunos Simulazioni

I had a similar problem, I use "Location" to mean position + orientation + scale.
I guess that works, but Location doesn't imply rotation and scale.
One of the dictionary definitions of "situation" means position and orientation; however, this is not one of the common modern usages of the word. The verb form "situate" is less ambiguous for that purpose.
A relatively sane name for a pos+quat would be 'rotor' (google rotors and geometric algebra). Otherwise I'd stick with PosQuat (my personal preference). Using 'transform' implies that the PosQuat supports translation, rotation, scaling, shearing and reflection. Which it doesn't.
Another term is "spatial data"
Quite honestly, its whatever works for you/whatever you want it to be. If you are working with colleagues, just have it documented so that they know what exactly it is.

Abbreviation always works to. But, again, document. Even for yourself. Once your code amounts to 100,000 lines and your looking for what that one function does, you'll wish you documented.
Morley

Aspiring programmer, modeler and game designer.

This topic is closed to new replies.

Advertisement