Jump to content
  • Advertisement
Sign in to follow this  
Ritti

multianimation sample with own meshes

This topic is 2620 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

As the topic says I'm trying to use my own meshes in the DX SDK sample multianimation.

The mesh appears for one frame, then it disappears. It appears to be because of

D3DXMatrixMultiply( &pFrame->TransformationMatrix,
&pFrame->TransformationMatrix,
pmxBase );

in AnimationInstance.cpp

As I read in a thread here it doesn't reset to the original value but it multiplies by itself so if the value is (0,0,2) then it gets (0,0,4) (0,0,8) (0,0,16) and so on

How can I adjust this function to work properly with my mesh?

In the thread I read the author said he had to inverse the multiplication to undo the changes but how?

The search function isn't working now so I cant find the thread, but I'll update this post as soon as I've found it.

Edit: This is the thread i mentioned
http://www.gamedev.net/topic/501879-multianimation-sample-seems-to-be-geared-to-only-loading-tiny/

I would appreciate if somebody could help me.

Thanks, Ritti

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!