Jump to content
  • Advertisement
Sign in to follow this  
Seabolt

[DX9] Z-Buffer not shared with all RenderTargets

This topic is 2473 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey guys,

I'm currently working on a post processing effect where I use MRT to output a Depth Buffer and a Color Buffer.

Now when I render the color buffer, everything looks fine, but when I render the depth buffer, I see the depth of pixels behind objects in the foreground, in the same sense as if I did not have Z-Testing on. The color buffer doesn't have this problem. And I do have Z-Testing on.

Is there something I need to do to enable Z-Testing on all Render Targets currently bound, or is this a more insidious issue?

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!