• Advertisement
Sign in to follow this  

problem about lesson 10

This topic is 2362 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i changed

xpos += (float)sin(heading*piover180) * 0.05f;
zpos += (float)cos(heading*piover180) * 0.05f;
into

xpos += (float)sin(heading*piover180) * 0.0005f;
zpos += (float)cos(heading*piover180) * 0.0005f;
then i run the program finding the scene shakes when i press UP or DOWN to move,
it doesn't move in a smooth way, can anyone tell how to solve this?

Share this post


Link to post
Share on other sites
Advertisement
It's most likely because the lesson doesn't use a delta time value, instead movement is based on how many frames are rendered, so any inconsistencies in the frame rate show up as shaking or stuttering in the movements, adding delta time compensates for that, so do skip ahead to lesson 32 an learn how to implement it.

Share this post


Link to post
Share on other sites

It's most likely because the lesson doesn't use a delta time value, instead movement is based on how many frames are rendered, so any inconsistencies in the frame rate show up as shaking or stuttering in the movements, adding delta time compensates for that, so do skip ahead to lesson 32 an learn how to implement it.


thank you

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement