• Advertisement
Sign in to follow this  

ATI Fullscreen gamma bug?

This topic is 2312 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

We've run into some troubles after I finally enabled the true fullscreen mode of our Engine:

Our Artist reported that the picture seems to have a higher gamma value when he is running the engine (Direct3D11, featurelevel 10)in fullscreen-mode. He wanted to send me a screenshot,
but after saving the image it just looked normal again. He captured the issue with his cellphone instead:
atigammabugpuf8.jpg

You can see the fullscreen-image being much darker than the one in windowed mode. Of course we also disabled our Postprocess-Effects in another test-run
to see if they might be the issue, but they weren't. So the HDR you see in the image isn't the problem.

I cannot reproduce this issue on my system (GTX570) and the screenshot he took was right as well.
He is even able to run other Direct3D11 applications in fullscreen as usual on his system, just our engine won't as it seems.
The GPU he is using is a HD4890 with the latest stable drivers.

Any help is appreciated!

Share this post


Link to post
Share on other sites
Advertisement
Sorry for the late reply. We are using DXUT, indeed. But unfortunately your solution isn't working.
We're using only very very few functions of it. It creates the Device, that was it. Swapchain and everything else gets created by myself.

And I also think I would see the gamma correction on my Nvidia card? Someone may have another idea?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement