Jump to content
  • Advertisement
Sign in to follow this  
665.999

Troubles with Allegro & Visual Studio 2010

This topic is 2528 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey everybody!

I'm using Visual Studio 2010 (Visual C++) and Allegro 5.0.4.

After following the first tutorial, and getting an error, and then following the second tutorial, and getting the same error, I figured I'd ask why this is happening and if I can get help on fixing it.
Tutorial 1: http://wiki.allegro.cc/index.php?title=Windows,_Visual_Studio_2010_and_Allegro_5
Tutorial 2: http://fixbyproximity.com/2011/07/2d-game-dev-installing-allegro-5-with-visual-studio-2010/

The error:
When I run either of the test builds in these tutorials, the black consol window will open up. Then, the debug window will start glitching out in my task bar below, sliding along down the task bar for no reason, fading in and out, and then the will stop and say: "Unhandled exception at *hex number* in AllegroTest.exe: *hex number*: Access violation reading location *hex number*. It then opens up a crtexe.c code file for some reason.

If anyone can help me get Allegro to work properly, that would be awesome. Thanks so much!

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!