Jump to content
  • Advertisement
Sign in to follow this  
wildboar

OpenGL Weird driver bug or what?

This topic is 2600 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have this strange strange bug in my OpenGL program.

C++ file:
GLint loc0 = water_main->GetProgramUniformLocation("DeltaTime"); //location is valid, I checked
glUniform4f(loc0, 1.0f, 1.0f, 1.0f, 1.0f);

fragment shader top:
uniform vec4 DeltaTime;

fragment shader inside main:
OUT_COLOR = vec4(DeltaTime.x, DeltaTime.y, DeltaTime.z, 1.0);

With that code, the fragment is not drawn at all, same effect as discard

if I do:
OUT_COLOR = vec4(1.0, 1.0, 1.0, 1.0);

then it works fine,
I tried clamping value, I tried many different things, same crap happens.

I am using 285.62 nvidia drivers on 590 gtx, anyone have some similar error?

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!