Jump to content
  • Advertisement
Sign in to follow this  
carmangary

[SlimDX] Direct3d bug

This topic is 2542 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I switched from SlimDX March to SlimDX September and not my 3D visualization that I created looks different. I didn't change anything on my end.

I don't know how to describe the change other than to say that there are black areas that mask part of the image. I don't see any changes in the SlimDX release notes that would explain this.

Are there SlimDX developers reading this that could shed some light? I had my visualization working perfectly in Managed DirectX and switched to SlimDX about 6 months ago and have had weird stuff like this happening ever since even though I am using the same methodology to render my images. Any help is appreciated in resolving this.

Share this post


Link to post
Share on other sites
Advertisement
Problem solved, although I don't know why it suddenly only became a problem with Sept 2011 SlimDX. The issue had to do with my view transform. Max distance was set to Z=327680 and my furthest point is hardcoded to have (0,0,327680). I changed my view to have a max distance of 327690 and the problem went away.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!