Jump to content
  • Advertisement
Sign in to follow this  
nchannon

debug error in DX(

This topic is 2585 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi I am getting a brakepoint error for some reason and im not sure what it means as I see no reason for my code not to work

[font="Consolas"][font="Consolas"]LPDIRECT3DSURFACE9 g_BackBuffer;
g_pd3dDevice->Clear(0, NULL, D3DCLEAR_TARGET, D3DCOLOR_XRGB(0, 0, 0), 1.0f, 0);
g_pd3dDevice->GetBackBuffer(0,0, D3DBACKBUFFER_TYPE_MONO, &g_BackBuffer);
hr = D3DXLoadSurfaceFromSurface(g_BackBuffer, NULL, NULL, g_LogoSurface, NULL, NULL, D3DX_FILTER_LINEAR, 0);
g_BackBuffer->Release();
g_pd3dDevice->Present( NULL, NULL, NULL, NULL );
g_BackBuffer->Release();[/font][/font]

[font="Consolas"][size="1"][font="Consolas"][size="1"]CCDFaceMgr.exe has triggered a breakpoint
Direct3D9: (ERROR) :************************************************************
Direct3D9: (ERROR) :ASSERTION FAILED! File e:\dxsdk\wggt_apr07\private\multimedia\directx\dxg\d3d9\fw\d3dobj.cpp Line 63: m_cRef > 0
Direct3D9: (ERROR) :************************************************************

Its strange as I do not have a E:\ partition and when I hit F5 to continue my image loads anyone got any idea why im getting this error
Thanks[/font][/font]

Share this post


Link to post
Share on other sites
Advertisement

Hi I am getting a brakepoint error for some reason and im not sure what it means as I see no reason for my code not to work

[font="Consolas"][font="Consolas"]LPDIRECT3DSURFACE9 g_BackBuffer;
g_pd3dDevice->Clear(0, NULL, D3DCLEAR_TARGET, D3DCOLOR_XRGB(0, 0, 0), 1.0f, 0);
g_pd3dDevice->GetBackBuffer(0,0, D3DBACKBUFFER_TYPE_MONO, &g_BackBuffer);
hr = D3DXLoadSurfaceFromSurface(g_BackBuffer, NULL, NULL, g_LogoSurface, NULL, NULL, D3DX_FILTER_LINEAR, 0);
g_BackBuffer->Release();
g_pd3dDevice->Present( NULL, NULL, NULL, NULL );
g_BackBuffer->Release();[/font][/font]

[font="Consolas"][size="1"][font="Consolas"][size="1"]CCDFaceMgr.exe has triggered a breakpoint
Direct3D9: (ERROR) :************************************************************
Direct3D9: (ERROR) :ASSERTION FAILED! File e:\dxsdk\wggt_apr07\private\multimedia\directx\dxg\d3d9\fw\d3dobj.cpp Line 63: m_cRef > 0
Direct3D9: (ERROR) :************************************************************

Its strange as I do not have a E:\ partition and when I hit F5 to continue my image loads anyone got any idea why im getting this error
Thanks[/font][/font]


http://www.gamedev.net/topic/523835-directx9-assertion-failure/

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!