Jump to content
  • Advertisement
Sign in to follow this  
Yartch

[SOLVED] Meshes rendering strangely

This topic is 2565 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I just started making a new engine for my game, but I'm running into trouble. These meshes display perfectly in my old engine. Now they it seems like some triangles are malformed, and there's a lot of little flickers happening on the meshes' textures.


I'm using a custom 3ds max exporting script. I've attached the file for the tree mesh.

I will post code tomorrow if the problem isn't solved, but I need to head to sleep now!


PS There isn't supposed to be a base on the first tower one, just poles extruding down.

Share this post


Link to post
Share on other sites
Advertisement
this is most likely an index problem. it looks to me like your indices might be off by like one or something, since the objects seems to be almost the right shape, but there are connections at certain points which makes me think that the index list is probably not aligned. try adding one to each index or subtracting one.

Share this post


Link to post
Share on other sites
Errr... I was using Triangle Strips for some reason, everything is perfect with Triangle Lists now.

Thanks though!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!