Jump to content
  • Advertisement
Sign in to follow this  
ShinkaFudan

OpenGL How do I disable the blended stretching effect

This topic is 2434 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

- Visual Studio
- SFML using OpenGL
- Textures loaded through SOIL
- C++

I have a texture that is literally just a 1x1 image, one pixel, that is the color green. When I stretch it to 32x32, I would expect that it would be a 32x32 texture of just that color green, but the edges are darker and I'm not sure why. I have tried enabling and disabling GL_BLEND, turning anti-aliasing on and off, changing the glBlendFunc settings... I get different results but never just the simple green square I would expect from stretching a 1x1 green pixel. Is this an issue anyone out there recognizes and knows the fix for off-hand?

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!