Jump to content
  • Advertisement
Sign in to follow this  
gatofedorento

OpenGL Problems with openGL picking

This topic is 2550 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey there, I'm making a GUI using the openGL library in C++ using class hierarchy, I haven't been coding it for some time and today I was adding some new features to it, the problem is glPopName causes an error and gives me this message:

Unhandled exception at 0x69afd9d1 in Dark Renaissance Fallen Empires.exe: 0xC0000005: Access violation reading location 0x0325d0dc.

It's the first time this happens and I only added two classes to my code, this problem doesn't happen everytime, and only when I use these two new classes, is there any known errors from glPopName that cause this or am I missing something in my code?

Do you want me to post it?

EDIT: me and my father have been making some tests, and looks like it's a visual studio problem, if i run the openGL program from my DEBUG/RELEASE directory everything runs great, the problem only occurs if i press the "play" button in VS, otherwise it works great

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!