Jump to content
  • Advertisement
Sign in to follow this  
nickme

windows.h compiling errors.

This topic is 2532 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

hi,
when i built a glut program, even i was successful and generated no error, i included windows.h as a header file. after ward, i added some code to include light in my program then i got the error as the following:

1>------ Build started: Project: 3D Solid mapping WITH LIGHT, Configuration: Debug Win32 ------
1> 3D Solid mapping with light.cpp
1>c:\program files (x86)\microsoft sdks\windows\v7.0a\include\windows.h(151): fatal error C1083: Cannot open include file: 'excpt.h': No such file or directory
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

i did not change the include files at all but i just added a normal and normalized function to calc the normal for my geometry.

any help will be appreciated.

Share this post


Link to post
Share on other sites
Advertisement
hi
i would like to add that the include files in my program are follow:

#include <Windows.h>
#include <stopwatch.h>
#include <GL/glut.h>
#include <math.h>

now i noticed the file math.h has wiggly line under it as well.

thanks

Share this post


Link to post
Share on other sites
Most likely you are missing a required include file, or your include pathing isn't set correctly. I can see from your error you are using the platform SDK, so it is probably looking there for excpt.h, but excpt.h isn't there. It is in the VS includes directory ( C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\include on my machine ).


Check your includes at [color=#000000][font=Arial,]Configuration Properties/C/C++/Advanced/Show Includes and verify it is included. In the includes section it will be listed using a variable, like ($VSInstallDir)/includes; or something similar.[/font]

Share this post


Link to post
Share on other sites
hi serath:

i think the problem started because win7 os update this morning gives me this problem. i did not alter the vs properties. now my previous run program have the same problem.

thanks

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!