Jump to content
  • Advertisement
Sign in to follow this  
Carbon101

Linking problems for both SDL and SFML

This topic is 2528 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have been having linking problems starting with SDL. Every time I debug, I keep getting this error message....


------ Build started: Project: Ultimate Pong, Configuration: Debug Win32 ------
LINK : fatal error LNK1104: cannot open file 'SDLmain.lib'
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I went to the Linker -> Input and I have everything I need. I followed the tutorial

I got frustrated and then I went to SFML and downloaded that. After I finished I went to Debug I got the following error message...


------ Build started: Project: SFML-Test, Configuration: Debug Win32 ------
LINK : fatal error LNK1104: cannot open file 'sfml-system-s-d.lib'
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========


I tried going to each individual forums but I have had no luck at all.

Share this post


Link to post
Share on other sites
Advertisement
Did you tell your IDE where to find the libraries? For MSVC you would add the directory the library is located add to the linker directories in VC++ Directories.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!