Jump to content
  • Advertisement
Sign in to follow this  
WireZappIndieStudios

DOF Issues

This topic is 2500 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

So I tried re-implementing the technique shown in this sample : http://mynameismjp.w...-ii-the-sequel/

And no matter what I do, my results always come out extremely blurry or with artifacts

Blurry:
[attachment=7100:AODGame 2012-02-08 15-32-26-51.bmp]

Here is my depth stencil state:

dsDesc.DepthEnable = true;
dsDesc.DepthWriteMask = D3D11_DEPTH_WRITE_MASK_ALL;
dsDesc.DepthFunc = D3D11_COMPARISON_LESS_EQUAL;
dsDesc.StencilEnable = false;
dsDesc.StencilReadMask = D3D11_DEFAULT_STENCIL_READ_MASK;
dsDesc.StencilWriteMask = D3D11_DEFAULT_STENCIL_WRITE_MASK;
dsDesc.FrontFace.StencilDepthFailOp = D3D11_STENCIL_OP_KEEP;
dsDesc.FrontFace.StencilFailOp = D3D11_STENCIL_OP_KEEP;
dsDesc.FrontFace.StencilPassOp = D3D11_STENCIL_OP_REPLACE;
dsDesc.FrontFace.StencilFunc = D3D11_COMPARISON_ALWAYS;
dsDesc.BackFace = dsDesc.FrontFace;


The shader is unmodified from the example

If I need to provide any more information to get help, please ask

Share this post


Link to post
Share on other sites
Advertisement
It's impossible to tell just from a screenshot...you might be generating the wrong CoC values, or you might just have bad focus parameters. I would check the output of the fullscreen shader that generates the initial depth + blur texture in PIX, and see if that matches what you expect. If that's not it, I would check the results of every other step along the way.

Share this post


Link to post
Share on other sites

It's impossible to tell just from a screenshot...you might be generating the wrong CoC values, or you might just have bad focus parameters. I would check the output of the fullscreen shader that generates the initial depth + blur texture in PIX, and see if that matches what you expect. If that's not it, I would check the results of every other step along the way.


Well I tracked it down to the initial depth + blur, and it seems it isn't generating a depth value that is >= 1. I will do further investigations tomorrow

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!