Jump to content
  • Advertisement
Sign in to follow this  
yilatil

OpenGL Rendering problem

This topic is 2487 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm not very sure if this is the right forum or should I post it to mobile development forum but I believe it's an OpenGL based problem.

I wrote some opengl code with C on windows, fully compatible with OpenGL ES. So without any changes (except a couple of context creation code) it worked on ios perfectly in terms of compilation, but has some problems with the result produced.

I can say the code has no problem because it works as it should on windows but it looks weird on ios.

It is like the polygons on the side that is close to camera are like not drawn. They appear as I rotate the object and another set vanishes. Here is a comparison image;

mrUiE.png

Share this post


Link to post
Share on other sites
Advertisement
[indent=1]Only thing that makes sense might be a depth precision issue. Do you have GL_CULL_FACE on? That might not be a tranparent/undrawn face, but the back face behind the triangle that is rendering a different color. What if you glScalef(2,2,2); so that it pushes the verts further apart in depth?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!