Sign in to follow this  

Stress testing flash player hardware acceleration

This topic is 2115 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi folks,

If you have a spare minute I would really appreciate if some of you could run the following demo and paste back some stats for me.

demo here: (you will need flash player 11 minimum, get it [url="http://get.adobe.com/flashplayer/"]here[/url] if it is not already installed)
[url="http://www.bwhiting.co.uk/b3d/stress/"]http://www.bwhiting.co.uk/b3d/stress/[/url]

controls:

Click to start.
WASD or LEFT/RIGHT/UP/DOWN to fly
Mouse move to look
Shift to fly faster
Space to toggle rotation
+ to add 500 doughnuts
- to remove 500 doughnuts
m to change material (4 available)

What I want to know is a rough spec of your machine?
i.e. fast/slow or more detailed like..
[color=#333333]Processor: Intel Xeon CPU E5405 @ 2GHz (2 processors)[/color]
[color=#333333]Ram: 12GB[/color]
[color=#333333]OS: Windows 7 (64bit)[/color]
[color=#333333]Browser: Chrome 17.0.9[/color]
[color=#333333]Flash Player: 11.1 r102 (release)[/color]
[color=#333333]GFX: NVIDIA GeForce 9800 GTX[/color]



Achieved frame rate (top left stat) i.e. 60 fps or 20fps
How many doughnuts you can handle before framerate starts to drop off, i.e. 1000, 2000, 10000...
And any other observations if you can be bothered :)
Oh and the green debug text should be copy/pasteable too so even if that is all I get back it might be helpfull

As you fly around the scene, if you are near the middle or near and edge and looking away from the centre most of the objects will be culled away, so if you really want to test your machine head for the edge of the scene and look back at it.

PS. I hope nobody's machine explodes [img]http://public.gamedev.net//public/style_emoticons/default/ph34r.png[/img]

Many thanks
(videos here if you can't get it to run, [url="http://blog.bwhiting.co.uk/?p=314"]blog post[/url])

Share this post


Link to post
Share on other sites
If i move back so all doughnuts are visible then i can handle 3500 objects without the fps dropping below 60

specs

C2D E8500@3.16Ghz
8GB Ram
GF9800GTX

If i leave the camera at the starting location i can reach around 36000 objects before it starts to drop to 55-58, around 1 million triangles(~1400 objects) rendered at 60fps without problems, 2 million tris still leaves me with a playable framerate.

I couldn't copy the green text without the camera spinning out of control changing the numbers.
but here is some of them

[code]
cullingTime: 2
occlusionTime: 0
sortingTime: 0
renderTime: 11
totalTime: 14
totalObjects: 25500
totalTriagles: 19125000
totalRenderedObjects: 2511
totalRenderedTriagles: 1883250 (10%)
totalProgramChanges: 0
DirectX9 :: hardware
[/code]

Share this post


Link to post
Share on other sites
27-30 f/s at the starting position (20 objects, 15000 triangles), dropping to 4 f/s when backed out (490 objects, 367500 triangles - 98%). At the starting position, frame rate drops off with objects as you'd expect - 1000 is 16 f/s, 1500 is 11, 2000 is 8. Green text: essentially all frame time was spent rendering.

i7 720QM, Radeon Mobility HD 4550, 4 GB RAM.

Share this post


Link to post
Share on other sites
[quote name='TheUnbeliever' timestamp='1330099279' post='4916234']
i7 720QM, Radeon Mobility HD 4550, 4 GB RAM.
[/quote]
Thanks unbeliever, very interesting indeed, I have ran this by someone else on an i7* and it handled it like Chuck Norris fighting a drunk 103 year old (no problems at all). I take it from the graphics card you are on a laptop of sorts? Its a shame I was hoping it would perform better 15,000 triangles at 30fps isn't exactly mind blowing performance.

Did you happen to notice if in the green text at the bottom it said "hardware" or "software", I am guessing hardware but worth checking as if it was software then hardware rendering has been disabled for some reason.

*I guess there are many versions of the i7 with quite the range?

Share this post


Link to post
Share on other sites
Intel i5 2500 (4x 3.3 GHz or something like that)
radeon hd 6870 (its factory overclocked i think)
8 gb 1600 mhz ram
windows 7
using newest firefox if that matters

If i position the camera so that all of them just fit on the screen (1920*1080), i can handle around 7000 objects DRAWN (if i go farther they get clipped...) at 60 fps before it starts dropping. Material doesnt really seem to affect performance.

It didnt seem to lag at all if theyre not visible with 160k of them (didnt want to spam + more... also was afraid of something crashing >_>) but if i look at them, visuals freeze until it has rotated away.

Looking at task manager performance seems to be CPU limited.

I can do 18k objects rendered at 30 FPS

Edit: turned hardware acceleration off, ~33k triangles at 60 fps

Share this post


Link to post
Share on other sites
[quote name='bwhiting' timestamp='1330100032' post='4916237']I take it from the graphics card you are on a laptop of sorts? Its a shame I was hoping it would perform better 15,000 triangles at 30fps isn't exactly mind blowing performance.[/quote]

Derp, apparently I had hardware acceleration turned off for some reason. (The green text read 'Software :: hardware', so I only checked on a whim.) Solid 60 f/s at all views of the starting cloud, then:

55 f/s with 17,500 objects (totalRenderedObjects: 579; totalRenderedTriangles: 434,250)
40 f/s with 31,000 objects (totalRenderedObjects: 1047; totalRenderedTriangles: 785,250)
30 f/s with 48,000 objects (totalRenderedObjects: 1604; totalRenderedTriangles: 1,203,000)
20 f/s with 82,000 objects (totalRenderedObjects: 2678; totalRenderedTriangles: 2,008,500)

Sorry about that!

Share this post


Link to post
Share on other sites
Win7 x64
Intel Core 2 Duo 2.13 GHz (E6400)
nVidia GeForce 8800 GTS
Chrome 17.0.963.56 m
Flash[font="Arial, Helvetica, sans-serif"][color="#333333"][size=2] [/size][/color][/font]11.1.102.62

50 FPS; Culling Time 2; Total Objects 23500; Rendered Objects 2500; Rendered Triangles ~1.9m
40 FPS; Culling Time 3; Total Objects 29000; Rendered Objects 3500; Rendered Triangles ~2.6m
30 FPS; Culling Time 5; Total Objects 43000; Rendered Objects 5200; Rendered Triangles ~3.9m
20 FPS; Culling Time 7; Total Objects 66000; Rendered Objects 9000; Rendered Triangles ~6.8m
10 FPS; Culling Time 0; Total Objects 30000; Rendered Objects 28000; Rendered Triangles ~21m

Share this post


Link to post
Share on other sites
Nvidia GTX570
AMD Phenom II 840 X4 ~3.20GHZ
Win7 x64

~3500 Rendered Objects: 60fps
~10100 Rendered Objects: 30fps
~23100 Rendered Objects: 15fps

Interestingly, the rendering seems to be having problems with more than 35k rendered objects. It wouldn't update the scene or the camera movement (GUI still works) till I moved the camera away to a point where no objects would get rendered.

Share this post


Link to post
Share on other sites

This topic is 2115 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this