Jump to content
  • Advertisement
Sign in to follow this  
almainv

DX11 Pix and SlimDx not working after Studio 11 Beta install

This topic is 2483 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi,

Pix stopped working for me after installing Studio 11 Beta.

Windows 7 Professional SP1 64 bits
SlimDX x86 (January 2012)
DirectX SDK (June 2010)
Project is x86

The program runs fine, pix lists events but even when I select a draw call it says
"not a draw call" and "mesh data is only available for draw calls"

Behavior is the same with DX11 or DX10 projects.

Has anyone managed to get pix working with studio 11 beta?

Thanks for your help.


[attachment=7549:pix.jpg]

Share this post


Link to post
Share on other sites
Advertisement
Hi!

I haven’t tried the new Visual Studio out yet. So I can’t help you with field experience. smile.png
But, wasn’t one of the new Visual Studio 11 features that PIX is now integrated in Visual Studio? They renamed it to “Graphics Debugger”. Maybe that one works for you.
Still, odd enough that the good old PIX causes problems after installing VS 11… huh.png
Which Windows SDK do you have, by the way? (DirectX updates are shipped in this SDK.)

Cheers!

Share this post


Link to post
Share on other sites
I tried to use Graphics Debugger but can't seem to get it to run with managed code.
The studio 11 installer installed SDK 8.0

I'll give Graphics Debugger another shot.

Thanks

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!