Jump to content
  • Advertisement
Sign in to follow this  

Porting Dustforce to OS X

This topic is 2781 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I've started porting our game Dustforce to OS X, and it's going pretty well so far, the debug build is actually up and running.
But as soon as I try to run the game with a release build of AngelScript I get a null pointer access on the first reference the code comes across which has been returned from the application (i.e. script classes being instantiated seem to work fine).
And if I comment that code out, the next reference it tries to access is null, and so on.

It seems to be when I enable optimisations, even the first level, if I disable optimisations in the release build it works, or enable them in the debug build it fails.

To isolate the problem, I added the array add-on to the "tutorial" sample, and put this code in the script:

array<uint> arr;

And I get a null pointer access on arr.resize(5);
I stepped in to the factory function and confirmed that it's not returning null...

I'm using Xcode 4.2.1 and I've tried AngelScript 2.22.1 and 2.22.2
I've tried building from the included Xcode project file, and also just adding the AngelScript cpp files to the Dustforce project.

I'll keep trying, but much of the internals of AngelScript are a bit over my head.
Any help would be greatly appreciated.


Share this post

Link to post
Share on other sites
Is this 32bit or 64bit?

I fixed a problem on Mac OS X in version 2.23.0 (WIP), but it was that floats and doubles weren't correctly returned when the library was compiled without optimizations so I don't think it is related to your problem.

Have you been able to determine exactly where the null pointer access is occurring? If I knew that I might be able to determine the problem by reviewing the code around it.

It must be something specific to Mac or perhaps the Clang compiler that it uses. Unfortunately I do not have a more up-to-date Mac so I don't think I'll be able to reproduce this problem on my own, but I'll fire up my MacMini and give it a try when I come home later today.

Share this post

Link to post
Share on other sites
Thanks Andreas, I'm using 32 bit Intel (i386), I haven't tried 64 bit, will do that today.
I've only been using Xcode for a couple of days, so I'm not very proficient at using the debugger, but I'll try to narrow down where it's going wrong.

Edit: Yep 64 bit works fine.

Edit2: After some more digging around, it appears that the constructor is not returning a NULL pointer, and the value of retQW immediately after calling
retQW = CallCDeclFunctionQWord(args, paramSize<<2, (size_t)func);
is not 0, but if I print the value just outside the switch statement, it is 0.
This might be due to some code being optimised away, but this seems to be where the pointer becomes null.

Edit3: Kinda got it working, if I make retQW volatile it seems to prevent optimisations enough for it to work. This is using the GCC 4.2 compiler.

Share this post

Link to post
Share on other sites
I would have imagined a problem in the inline assembly code, not in the C++ function itself. This might be a bug in the GCC compiler itself, because I don't think it should be allowed to optimize away the assignment of the retQW variable in this code as it is later returned to the caller.

Still if making the variable volatile helps, then I'll apply it.

[edit] I've checked in this change in revision 1225.

Share this post

Link to post
Share on other sites
Thanks Andreas, I'll see if I can get a better idea of what's happening, my solution does feel like it's just hiding some underlying issue (which may well be in the compiler)
I've come across some other strange behaviour, I'm not certain yet if it's related to AngelScript or not, but it also only occurs with optimisations enabled..
Will look in to it more tomorrow.


Share this post

Link to post
Share on other sites
Sign in to follow this  

  • Advertisement

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!