Jump to content
  • Advertisement
Sign in to follow this  
lomateron

This must be a bug, on the textures(maybe)

This topic is 2478 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

when drawing 2d textures,have you never notice, all the pixels that are at the right, i mean the last column of pixels from left to right of the texture, and the first row of pixels from up to down.With those pixels, if you draw the texture into a 2d square, the column of pixels will appear at the left side of the square, and the row of pixels will appear at the bottom part of the square, looks more like if the texture was moved and the pixels that were offset were moved to the other side. Why is this?

Share this post


Link to post
Share on other sites
Advertisement
Sounds like texture wrapping issue? Set texture address mode to clamp perhaps?

Cheers!

Share this post


Link to post
Share on other sites

d3d->SetSamplerState(0, D3DSAMP_ADDRESSU, D3DTADDRESS_MIRROR);
d3d->SetSamplerState(0, D3DSAMP_ADDRESSV, D3DTADDRESS_MIRROR);

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!