Jump to content
  • Advertisement
Sign in to follow this  
O-san

Normals inconsistent

This topic is 2465 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello!

I have a problem with normals. They look slightly different in two different programs (game and editor). A picture to illustrate:

1.png

The game normals produce a slightly more round shape while the editor has the result I am looking for. I have been looking through my code searching for the cause of the inconsistency but can't find it. I am 99% certain that the normal and light positions have the same values:

2.png

I have tried glEnable(GL_NORMALIZE) and glLightModeli(GL_LIGHT_MODEL_LOCAL_VIEWER, GL_FALSE) (and true). Are there any other functions that I might have overlooked that can produce these differences?

Thanks for reading!

Share this post


Link to post
Share on other sites
Advertisement
Well, it wasn't the normals or the lighting that was the problem. I had optimized the geometry in the game so the edges where lying differently. Problem solved :)

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!