Jump to content
  • Advertisement
Sign in to follow this  
Shawn619

OpenGL Opengl - linker errors

This topic is 2375 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

While attempting to incorporate shaders for PPL, i think i accidently removed a few includes and now my program wont run even with commenting out all the glsl code and reverting back to my original program.
The errors:

1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutSwapBuffers@0"]__imp__glutSwapBuffers@0[/email] referenced in function "void __cdecl drawScene(void)" ([email="?drawScene@@YAXXZ"]?drawScene@@YAXXZ[/email])
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutTimerFunc@12"]__imp__glutTimerFunc@12[/email] referenced in function "void __cdecl update(int)" ([email="?update@@YAXH@Z"]?update@@YAXH@Z[/email])
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutPostRedisplay@0"]__imp__glutPostRedisplay@0[/email] referenced in function "void __cdecl update(int)" ([email="?update@@YAXH@Z"]?update@@YAXH@Z[/email])
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutMainLoop@0"]__imp__glutMainLoop@0[/email] referenced in function _main
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutReshapeFunc@4"]__imp__glutReshapeFunc@4[/email] referenced in function _main
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutKeyboardFunc@4"]__imp__glutKeyboardFunc@4[/email] referenced in function _main
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutDisplayFunc@4"]__imp__glutDisplayFunc@4[/email] referenced in function _main
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutCreateWindow@4"]__imp__glutCreateWindow@4[/email] referenced in function _main
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutInitWindowSize@8"]__imp__glutInitWindowSize@8[/email] referenced in function _main
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutInitDisplayMode@4"]__imp__glutInitDisplayMode@4[/email] referenced in function _main
1>main.obj : error LNK2019: unresolved external symbol [email="__imp__glutInit@8"]__imp__glutInit@8[/email] referenced in function _main
1>C:\Users\Shawn\Documents\New folder\First Project - visual\Light\Debug\Light.exe : fatal error LNK1120: 11 unresolved externals

They appear to be glut errors, but beyond that im not sure.
I tried to backtrack and figure what i did wrong. So i'll name off the things i currently have in my program and whether or not i changed them while trying to get my shader to work.
Includes: (I did remove 1 or 2 that may have caused these errors)

C:\Users\Shawn\Documents\New folder\First Project - visual\Light\Light\glew\include
C:\Users\Shawn\Documents\New folder\First Project - visual\Light\Light\cwc\include
C:\Users\Shawn\Documents\New folder\First Project - visual\Light\Light\freeglut\include
C:\Program Files %28x86%29\Microsoft Visual Studio 10.0\VC\include

Linkers:(Never touched)

SOIL.lib glu32.lib opengl32.lib

And the includes in my program:

#include <stdlib.h>
#include <gl/glut.h>
#include <SOIL.h>
#include <string>
#include <iostream>

I would greatly appreciate help!

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!