Sign in to follow this  

disabling output filtering in windowed DirectX9

This topic is 2083 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm using DirectX9 for rendering video output onto the screen .
The library used is SlimDX.

The software created is used for marking bad pixels from the output device so it's vital that no texture filtering / smoothing is done.

I disabled all the texture filtering options , disabled anti-aliasing , and aligned the texture to the screen at 1:1 ratio between the backbuffer and the rendered texture.
Thing is , on some devices , DirectX seems to be doing some bilinear filtering / blurring on the output.

I need all the output to be blocky , with -0- filtering.
Since all the resize code is operated on the control itself ( no backbuffer resizing etc' ) , I don't have the option of resizing the backbuffer.

Weird thing is , this only happens on some devices , not all.

How do I tell DirectX not to smooth what it renders to the control ? ( disable whatever texture filtering is done to the back/front buffer )

Thanks in advance for any help (:

Share this post


Link to post
Share on other sites

This topic is 2083 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this