Jump to content
  • Advertisement
Sign in to follow this  
Shawn619

OpenGL OpenGL shader problem

This topic is 2352 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I tried implementing a shader into my program.
The shader is from an example program from http://www.swiftless...g_perpixel.html
I included all the necessary files, shader.cpp, shadder.h, i have shader.vert and shader.frap in the appropriate directories. Also i have glew32.lib linked appropriately as well, just as in the example on the website.
Running my program, i get this error ->
21k0bw2.jpg
If it helps, here's my .exe directory ->
10f80m8.jpg

Share this post


Link to post
Share on other sites
Advertisement
glCreateShader needs to be loaded by glew ... where is your glewInit()? It must be called before you can call any of the newer functions like glCreateShader. Also, are you sure your GPU drivers support it (most likely supported with every non-ancient cards and non ancient drivers)?

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!