Sign in to follow this  

Black specs in normal mapping on nvidia

This topic is 2064 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey,

I'm having a problem with my normal mapping on nvidia cards that I just can't seem to fix and hope you guys could help me out.
Here are some pictures showing the problem, the last one shows the same scene on ATI but from a different place in the model.

[url="http://i.imgur.com/unzdx.jpg"]http://i.imgur.com/unzdx.jpg[/url]
[url="http://i.imgur.com/WgiIH.jpg"]http://i.imgur.com/WgiIH.jpg[/url]
[url="http://i.imgur.com/A0AAZ.jpg"]http://i.imgur.com/A0AAZ.jpg[/url]

ati: [url="http://i.imgur.com/5Oa5b.png"]http://i.imgur.com/5Oa5b.png[/url] (works as intended)


I found out that the problem is my shininess float value that I send into the shader. If it's 0.0f it seems like the shader on nvidia thinks its undefined or some other weird value. If I hardcode 0.0 as shininess into the specular component it works just fine.

Any idea how this could happen?

Share this post


Link to post
Share on other sites
If you look at the [font=courier new,courier,monospace]pow[/font] function in the GLSL specification, you can see that if both parameters are zero ([i]e.g. zero spec mask and zero spec power[/i]), then the result is undefined -- each card can generate a different result. It's likely that one of your cards is producing 0.0f as the result, and the other is generating NaN ([i]which propagates through the rest of your shader, causing black speckles[/i]).

Share this post


Link to post
Share on other sites
Hey, thanks for your replies.
I was thinking about undefined value, but what is really odd is that if I hardcode this: float spec = pow(max(0.0, dot(r, e)), 0.0) it works just fine. When I send 0.0 to the shader however, black specks everywhere. I cant explain that :S

Here's my shader code:
[CODE]
#version 110

uniform sampler2D tex;
uniform sampler2D bmap;
uniform bool boolBump;
uniform vec4 vecColor;
uniform bool onlyColor;

uniform float fTransparencyThresh;
uniform float fShininess;
uniform float alpha;

varying vec3 vecLight;
varying vec3 vecEye;
varying vec3 vecNormal;

vec4 getLighting()
{
//Ambient part
vec4 color = (gl_FrontLightModelProduct.sceneColor * gl_FrontMaterial.ambient) + (gl_LightSource[0].ambient * gl_FrontMaterial.ambient);

//For bump mapping, the normal comes from the bump map texture lookup
vec3 n = normalize(vecNormal);
if(boolBump)
{
n = normalize(texture2D(bmap, gl_TexCoord[0].st).xyz * 2.0 - 1.0);
}

vec3 l = normalize(vecLight);

//Lambert term
float NdotL = dot(n, l);
color += gl_LightSource[0].diffuse * gl_FrontMaterial.diffuse * max(0.0, NdotL);

//Reflection term
if(NdotL > 0.0)
{
vec3 e = normalize(vecEye);
vec3 r = normalize(-reflect(l,n));

float spec = pow(max(0.0, dot(r, e)), fShininess);
color += gl_LightSource[0].specular * gl_FrontMaterial.specular * spec;
}

return color;
}

void main(void)
{
vec4 texel = texture2D(tex, gl_TexCoord[0].st);
if(texel.a < fTransparencyThresh)
discard;

//Get shading
vec4 color = getLighting();

//Color only mode?
if(onlyColor)
{
color *= vecColor;
}
else
{
color *= texel;
}
//Set fragment color, alpha comes from MTL file
gl_FragColor = vec4(color.xyz, alpha);
}
[/CODE]

Share this post


Link to post
Share on other sites
[quote name='frna' timestamp='1335142632' post='4933917']but what is really odd is that if I hardcode this [0.0] it works just fine. When I send 0.0 to the shader however, black specks everywhere. I cant explain that :S[/quote]When you hard-code a value, the resulting shader assembly will be completely different, largely thanks to the optimising compiler used by your driver. It's possible that with the hard-coded version, the optimiser has said "[i]anything to the power of zero is one, and anything multiplied by one is unchanged, so I'll just remove that code[/i]", whereas when you use a uniform, it actually computes 0[sup]^0[/sup] and gets the undefined result of NaN.

Share this post


Link to post
Share on other sites
I see, that would make more sense to me thanks @Hodgman.

@dpadam450 yes the shader is bound and getUniform returns a location.

What I'm doing now is to check if dot(r,e) > 0.0 and only enter the specular part if that's true. Seems to work fine. Do you reckon that's a valid solution? Any better suggestions?

Share this post


Link to post
Share on other sites
The other suggestion would be to send 1 instead of 0. You shouldnt see much or any difference between those. If you want no specular, you should be setting the glFrontMaterial.specular to 0. If you just want it to have flat specular instead of really "tight" specular, then just use 1.

Share this post


Link to post
Share on other sites
A spec power of 1 is equivalent to a perfectly rough/diffuse surface, and numbers lower than 1 aren't very useful. e.g. when decoding spec-power values from a texture, I'd use something like [font=courier new,courier,monospace]specPow = tex*8192 [b]+ 1[/b][/font].
If you want to remove specular from a material, set the spec-mask to 0 instead ([i]gl_FrontMaterial.specular[/i]).

Share this post


Link to post
Share on other sites

This topic is 2064 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this