Sign in to follow this  

[SOLVED]Problems with Vertex- and Indexbuffer

This topic is 1951 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi there,

As some of you know, we are programming an MineCraft-like game.
This works very well.

We are allowed to flyring around, selecting blocks, etc....

Now we have a real problem. We want to add a block if somebody clicks the left mousebutton.
But if we add a block we have a graphic problem.

The world is divided in chunks (16*16*16 blocks).
If we add a block or sometimes if we are flying around some chunks are going to dissapear.
We don't know why and so we want to ask you if you can help us.

I've added the complete sourcecode.

Feel free to use it for your own projects if you want.

[attachment=8694:Kubos.rar]

[color=#ff0000]--------------------------------------------------------------------------------------------[/color]

[color=#ff0000]Problem solved.[/color]
[color=#ff0000]In Class "Chunks"->prepare we forgot to reset the variable "index" to "0";[/color]

Share this post


Link to post
Share on other sites
I've forgot to upload the final source-code.
We have got an 1.0 (excellent) for our Project.

Thanks to all who helped us.

Here is the final sourcecode.
Feel free to use it for your own projects.

Share this post


Link to post
Share on other sites

This topic is 1951 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this