Jump to content
  • Advertisement
Sign in to follow this  
Mr.L

Sdlnet_tcp_send blocking reason

This topic is 2266 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i'm working on simple programm that is just repeatedly sending an reseving messages von the other endpoint.
Then i noticed that when block both a little with sdl_delay(40)(Client) and sdl_delay(30)(server)
then sdlnet_tcp_send isn't blocking if there's no time between the sendings, it sends a few times, then it blocks for about 30 seconds, sends a few time, blocks, and so on.

why does tcp_send block , when i don't use delay?

Share this post


Link to post
Share on other sites
Advertisement
You're probably trying to send too much data, so it has to block, waiting for the buffer to drain to the other end.

Share this post


Link to post
Share on other sites
i think not, im just sending 128 bytes, and it blocks after about 50 sends.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!