Sign in to follow this  

compiling ode with mingw

This topic is 2039 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I've download ode 0.12 from sourceforge, and I'm trying to compile it with mingw via the bash shell (under windows 7).

I've followed the instructions in the INSTALL file, but I cannot get it to successfully make.

I tried configuring in a few different permutations:
[code]
./configure --enable-shared --enable-double-precision
./configure --enable-shared --enable-double-precision --disable-asserts
./configure --enable-shared --enable-double-precision --disable-asserts --with-trimesh=none
[/code]

But each time I run make, it gets stuck at this part:
[code]

Creating library file: .libs/libode.dll.a
libtool: link: (cd .libs/libode.lax/libfast.a && ar x "/e/code/ode-0.12/ode/src/./.libs/libfast.a")
libtool: link: object name conflicts in archive: .libs/libode.lax/libfast.a//e/code/ode-0.12/ode/src/./.libs/libfast.a
make[4]: *** [libode.la] Error 1
make[4]: Leaving directory `/e/code/ode-0.12/ode/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/e/code/ode-0.12/ode/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/e/code/ode-0.12/ode/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/e/code/ode-0.12/ode'
make: *** [all-recursive] Error 1
bash.exe"-3.1$[/code]

So far I haven't found anyone on google with the same problem. So anyone got a clue what the problem is?

Thanks. Edited by andrew111

Share this post


Link to post
Share on other sites

This topic is 2039 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this