Sign in to follow this  
Tallkotten

Problems with code::blocks compiling(build and run)

Recommended Posts

Tallkotten    288
Hello!

Only just recently I've begun to experience problems when building a project in Code::blocks. It has gotten to the point where i cant see a simple change in a variable eg:
[source lang=java]for(int i = 0; i < 10; i++)

//changed to

for(int i = 0; i < 5; i++)[/source]

Unless i rebuild the entire project which is very tiring and becomes quite a hassle if you are trying to fix a specific problem which only includes one file. At first i thought that it should work if i choose to build ONLY the file which I've changed something in since the last build, which also made sense. But no, i have to rebuild it all.

I think i know what the problem is. Is doesn't create a new .exe fun unless i rebuild it. I've confirmed this by looking at the time last changed on the file, and it doesn't change if i "build & run" which it did before.

Anyway I've tried to re-install it and it didn't help at all and I've found near to nothing when google:ing. I really do hope that i can get some help from here!

Thanks alot for taking the time to read my post smile.png

Share this post


Link to post
Share on other sites
?????????    199
Code::Blocks comes with a bunch of plugins pre-installed. Perhaps one of them is causing the problem. Using the plugin manager you can disable and uninstall some plugins. Try that for a fix.

Share this post


Link to post
Share on other sites
Tallkotten    288
This is my build log after pressing F9 (build and run)

"Checking for existence: C:\Users\Johan\Documents\CodeBlocks\Spel\bin\Debug\Spel.exe
Executing: "C:\Users\Johan\Documents\CodeBlocks\Spel\bin\Debug\Spel.exe" (in C:\Users\Johan\Documents\CodeBlocks\Spel\.)
Process terminated with status 0 (0 minutes, 2 seconds)"

It never seems to make a new exe :/

Share this post


Link to post
Share on other sites
Tallkotten    288
I posted the same problem on the Code::Blocks forum and I've finally solved it.

Here is the link to the forum-thread:
[url="http://forums.codeblocks.org/index.php/topic,16540.new.html#new"]http://forums.codeblocks.org/index.php/topic,16540.new.html#new[/url]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this