Jump to content
  • Advertisement
Sign in to follow this  
auto.magician

DX11 DX11 IDXGIAdapter.CheckInterfaceSupport bug

This topic is 2345 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hiya,

I had a problem with IDXGIAdapter.CheckInterfaceSupport returning that a Radeon Dx11 gpu didn't support the Dx11 interface, but was ok with 10.1. However Dx11 was available through using D3D11CreateDevice, so after a quick work-around, I change my code to support that command.
After I had my code working correctly and reporting as expected I then scouted the internet, only to find references to this issue with Dx10 devices which were back in 2009/2010.

Does anyone know if this bug has supposed to have been fixed just yet?

I would ask over on the MSDN but well.... not meaning to sound rude but it seems a waste of time asking anything there lately.

Many thanks in advance.

Dave.

Share this post


Link to post
Share on other sites
Advertisement
I'd double-check that you're getting the results for the correct adapter - e.g. you may have switchable graphics and be pulling the results for the Intel (which would be 10.1).

Share this post


Link to post
Share on other sites
Hi,

yes, that was the first thing I thought of, but there's only 1 card though and only 1 adapter returned. There's no internal motherboard gpu or cpu/gpu combination that may create an extra entry for an adapter. Edited by auto.magician

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!