Jump to content
  • Advertisement
Sign in to follow this  
d07RiV

OpenGL AppVerifier breakpoint in glDrawPixels

This topic is 2290 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm using OpenGL to draw some stuff in my windower app, and I've noticed some suspicious behavior and crashes. I ran it with app verifier, and, sure enough, it was crashing on glDrawPixels call. I checked the arguments, they all appear valid. Here's approximately what happens:

glPixelStorei(GL_UNPACK_ROW_LENGTH, 12); // this is in case I need to draw a fragment instead of the whole image
glRasterPos2i(300,400); // sample values; using glOrtho so I can supply actual window coordinates
glPixelZoom(1,-1); // so I don't have to keep a flipped copy of the image; if I remove this it still crashes
glDrawPixels(12, 12, GL_BGRA_EXT, GL_UNSIGNED_BYTE, ptr); // ptr is a valid pointer to a 12x12 image with 32bpp; this line triggers a breakpoint


The error message isn't very informative, read access violation at 0xFFFFFFFF.

This time it's not a driver issue, it crashes on two different computers, one had the driver updated yesterday, another like a month ago.

Edit: I tried switching to textures, now it crashes on glGenTextures call when I'm generating textures on the fly.. apparently there's some problem with the context, how could it happen? Edited by d07RiV

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!