Jump to content
  • Advertisement
Sign in to follow this  
jdub

[Allegro]Why can't I load this font?

This topic is 2149 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have this code:
//init allegro
if(!al_init()) {
fprintf(stderr, "failed to initialize allegro!\n");
return -1;
}
al_init_font_addon();
if(!al_init_ttf_addon())
{
return -1;
}
//create the display
this->display = al_create_display(640, 480);
if(!this->display) {
fprintf(stderr, "failed to create display!\n");
return -1;
}
if(!al_install_keyboard())
{
return -1;
}
//init font
this->font = al_load_ttf_font("pirulen.ttf", 72, 0);
if(!this->font)
{
return -1;
}


for some reason al_load_ttf_font() fails. Tried everything I can think of. pirulen.ttf is in the top directory of my project as well as being in the debug and release folders of the project. Any ideas on what's going on here?

Share this post


Link to post
Share on other sites
Advertisement
The first thing you should do is link with a debug version of allegro and look at allegro.log. al_load_ttf_font will print a message there including a FreeType error code when a font fails to load. That will probably point you in the right direction.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!