Sign in to follow this  

Problem with cgSetPassState()

This topic is 1949 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello,
I'm having a headache with cgSetPassState(pass) function. Basically, when I call it, all geometry disappears. I've already spent several days trying to figure out what's wrong, but no luck. When I comment the line with it, it's all right, but I want to setup some samplers and I have to use cgSetPassState() . Cg doesn't output any errors which makes things even worse. [img]http://public.gamedev.net//public/style_emoticons/default/unsure.png[/img] To be more specific, I'm not changing any states in my shaders and I'm using CgFX files, so each shader is in separate pass. According to this [url="http://www.pouet.net/topic.php?which=7391"]http://www.pouet.net....php?which=7391[/url] I have to use cgSetPassState, but for some reason it messes up my rendering and I'm stuck.

Share this post


Link to post
Share on other sites

This topic is 1949 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this