Jump to content
  • Advertisement
Sign in to follow this  
Mona2000

SetClipPlane weirdness

This topic is 2128 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm developing a game, and I use user clip planes to render water reflections. Normally the code runs fine, but randomly it fails to work (no clipping at all). The calls to SetClipPlane and SetRenderState(D3DRS_CLIPPLANEENABLE, D3DCLIPPLANE0) succeed, GetClipPlane and GetRenderState report that the clip plane is active and has the correct values... but it just doesn't clip anything.
This happens to me and 2 other users (all 3 with an AMD graphics card) - is there an issue with how it's implemented in the AMD driver? Is there a hack that I have to use to make it work (I have already tried this, to no avail)?

I'm not sure if it's relevant, but SetClipPlane doesn't seem to work with the reference rasterizer. Ever.
And yes, I am aware that I can achieve the same result with texkill/clip in the Pixel Shader, but the thread is not about that. smile.png

Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!