Jump to content
  • Advertisement
Sign in to follow this  
mrmurder

OSX GLSL1.5 Can't use directives as GL_EXT_gpu_shader4

This topic is 2126 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey all,

Anyone had problems with directives in GLSL under GL3.2 context before ?

I'm trying to use Texture Buffer Objects in my application on GLSL 1.5 shader but i keep getting these errors telling me its not supported

WARNING: 0:3: extension 'GL_EXT_geometry_shader4' is not supported
WARNING: 0:4: extension 'GL_EXT_gpu_shader4' is not supported
ERROR: 0:33: Call to undeclared function 'texelFetchBuffer


Im using the new macbook pro with nvidia 650m so it shouldn't be a problem. Also checking for the extension it tells me they exist, so why would the shader complain when i try to enable them ?

Any ideas ?

Thanks in advance Edited by mrmurder

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!