• Announcements

    • khawk

      Download the Game Design and Indie Game Marketing Freebook   07/19/17

      GameDev.net and CRC Press have teamed up to bring a free ebook of content curated from top titles published by CRC Press. The freebook, Practices of Game Design & Indie Game Marketing, includes chapters from The Art of Game Design: A Book of Lenses, A Practical Guide to Indie Game Marketing, and An Architectural Approach to Level Design. The GameDev.net FreeBook is relevant to game designers, developers, and those interested in learning more about the challenges in game development. We know game development can be a tough discipline and business, so we picked several chapters from CRC Press titles that we thought would be of interest to you, the GameDev.net audience, in your journey to design, develop, and market your next game. The free ebook is available through CRC Press by clicking here. The Curated Books The Art of Game Design: A Book of Lenses, Second Edition, by Jesse Schell Presents 100+ sets of questions, or different lenses, for viewing a game’s design, encompassing diverse fields such as psychology, architecture, music, film, software engineering, theme park design, mathematics, anthropology, and more. Written by one of the world's top game designers, this book describes the deepest and most fundamental principles of game design, demonstrating how tactics used in board, card, and athletic games also work in video games. It provides practical instruction on creating world-class games that will be played again and again. View it here. A Practical Guide to Indie Game Marketing, by Joel Dreskin Marketing is an essential but too frequently overlooked or minimized component of the release plan for indie games. A Practical Guide to Indie Game Marketing provides you with the tools needed to build visibility and sell your indie games. With special focus on those developers with small budgets and limited staff and resources, this book is packed with tangible recommendations and techniques that you can put to use immediately. As a seasoned professional of the indie game arena, author Joel Dreskin gives you insight into practical, real-world experiences of marketing numerous successful games and also provides stories of the failures. View it here. An Architectural Approach to Level Design This is one of the first books to integrate architectural and spatial design theory with the field of level design. The book presents architectural techniques and theories for level designers to use in their own work. It connects architecture and level design in different ways that address the practical elements of how designers construct space and the experiential elements of how and why humans interact with this space. Throughout the text, readers learn skills for spatial layout, evoking emotion through gamespaces, and creating better levels through architectural theory. View it here. Learn more and download the ebook by clicking here. Did you know? GameDev.net and CRC Press also recently teamed up to bring GDNet+ Members up to a 20% discount on all CRC Press books. Learn more about this and other benefits here.
Sign in to follow this  
Followers 0
Mariusz Pilipczuk

GLSL Vertex Shader error

6 posts in this topic

Hello, I get an error while compiling my vertex shader. Here is the code for my shader:

[CODE]
/*
MaddEngine.vert
GLSL vertex shader used by Madd Engine
*/
void main()
{
gl_TexCoord[0] = gl_MultiTexCoord0;
gl_Position = gl_ProjectionMatrix * gl_ModelViewMatrix * gl_Vertex;
}
[/CODE]

When I run my application, it outputs the InfoLog to a file, here it is:

[CODE]
Vertex info
-----------
(0) : error C0000: syntax error, unexpected $end at token "<EOF>"
(0) : error C0501: type name expected at token "<null atom>"
[/CODE]

The same error occurs even if I comment out the entire shader code. Does anyone know where the problem is?

P.S. The fragment shader works as it should, here is the code:

[CODE]
/*
MaddEngine.frag
GLSL fragment shader used by Madd Engine
*/
uniform sampler2D tex;
void main()
{
vec4 texel = texture2D(tex, gl_TexCoord[0].st);
gl_FragColor = gl_Color * texel;
}
[/CODE] Edited by Madd
0

Share this post


Link to post
Share on other sites
Is the loading code different for vertex shader? Feels like you have messed up something there.
2

Share this post


Link to post
Share on other sites
Is it possible you have invalid characters in the file? Depending on the editor an invalid character can easily slip with a copy'n'paste or accidental hotkey. A lot of editors will then pick a suitable encoding to encode the undesired character and it will often be invisble to the naked eye then.
Have you tried explicitely forcing ANSI encoding on the file (for example in Notepad++ Encoding->Convert to ANSI)? If the problem is a rogue character it will usually show up in an obvious way (the not-in-font symbol or 'weird' symbols).
0

Share this post


Link to post
Share on other sites
Here's the code for the loader:

[source lang="cpp"]
void meEnableShaders()
{
/* load the fragment shader */
char *frag_buffer, *vert_buffer;

FILE *fp = fopen("MaddEngine.frag", "rb");
int frag_size;
fseek(fp, 0, SEEK_END);
frag_size = ftell(fp);
fseek(fp, 0, SEEK_SET);
frag_buffer = (char*)malloc(frag_size);
fread(frag_buffer, 1, frag_size, fp);
fclose(fp);

/* load the vertex shader */
fp = fopen("MaddEngine.vert", "rb");
int vert_size;
fseek(fp, 0, SEEK_END);
vert_size = ftell(fp);
vert_buffer = (char*)malloc(vert_size);
fread(vert_buffer, 1, vert_size, fp);
fclose(fp);

#ifdef ARB_SHADER
me_fragment_shader = glCreateShaderObjectARB(GL_FRAGMENT_SHADER_ARB);
glShaderSourceARB(me_fragment_shader, 1, &frag_buffer, &frag_size);
glCompileShaderARB(me_fragment_shader);

me_vertex_shader = glCreateShaderObjectARB(GL_VERTEX_SHADER_ARB);
glShaderSourceARB(me_vertex_shader, 1, &vert_buffer, &vert_size);
glCompileShaderARB(me_vertex_shader);

me_shader_program = glCreateProgramObjectARB();
glAttachObjectARB(me_shader_program, me_fragment_shader);
glAttachObjectARB(me_shader_program, me_vertex_shader);
glLinkProgramARB(me_shader_program);
glUseProgramObjectARB(me_shader_program);
#else
me_fragment_shader = glCreateShader(GL_FRAGMENT_SHADER);
glShaderSource(me_fragment_shader, 1, &frag_buffer, &frag_size);
glCompileShader(me_fragment_shader);

me_vertex_shader = glCreateShader(GL_VERTEX_SHADER);
glShaderSource(me_vertex_shader, 1, &vert_buffer, &vert_size);
glCompileShader(me_vertex_shader);

me_shader_program = glCreateProgram();
glAttachShader(me_shader_program, me_fragment_shader);
glAttachShader(me_shader_program, me_vertex_shader);
glLinkProgram(me_shader_program);
glUseProgram(me_shader_program);
#endif
free(frag_buffer);
free(vert_buffer);
};
[/source]


It is compiled without the ARB_SHADER macro (so it uses the standard OpenGL functions).

I edit the files with gedit under Ubuntu, which uses UTF-8. Edited by Madd
0

Share this post


Link to post
Share on other sites
After setting the stream to the end of the file and calling ::ftell(), you never set the stream back to the beginning of the file before you try to read it.
On the vertex shader.


L. Spiro


[EDIT]
I stopped reading as soon as I saw the problem. Even if it was just one last post with a single sentence explaining the solution.
[/EDIT] Edited by L. Spiro
2

Share this post


Link to post
Share on other sites
Even if the problem has been found, it isn't a good idea to read a text file as binary because on some systems (Windows), end of lines are in the form of \r\n or was it \n\r.
It is better to open the file this way
FILE *fp = fopen("MaddEngine.frag", "r"); //changed the "rb" to "r"

and the library will automatically convert all the \r\n to \n (newlines).

and it is a good idea to NULL terminate the file string yourself.
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0