• Announcements

    • khawk

      Download the Game Design and Indie Game Marketing Freebook   07/19/17

      GameDev.net and CRC Press have teamed up to bring a free ebook of content curated from top titles published by CRC Press. The freebook, Practices of Game Design & Indie Game Marketing, includes chapters from The Art of Game Design: A Book of Lenses, A Practical Guide to Indie Game Marketing, and An Architectural Approach to Level Design. The GameDev.net FreeBook is relevant to game designers, developers, and those interested in learning more about the challenges in game development. We know game development can be a tough discipline and business, so we picked several chapters from CRC Press titles that we thought would be of interest to you, the GameDev.net audience, in your journey to design, develop, and market your next game. The free ebook is available through CRC Press by clicking here. The Curated Books The Art of Game Design: A Book of Lenses, Second Edition, by Jesse Schell Presents 100+ sets of questions, or different lenses, for viewing a game’s design, encompassing diverse fields such as psychology, architecture, music, film, software engineering, theme park design, mathematics, anthropology, and more. Written by one of the world's top game designers, this book describes the deepest and most fundamental principles of game design, demonstrating how tactics used in board, card, and athletic games also work in video games. It provides practical instruction on creating world-class games that will be played again and again. View it here. A Practical Guide to Indie Game Marketing, by Joel Dreskin Marketing is an essential but too frequently overlooked or minimized component of the release plan for indie games. A Practical Guide to Indie Game Marketing provides you with the tools needed to build visibility and sell your indie games. With special focus on those developers with small budgets and limited staff and resources, this book is packed with tangible recommendations and techniques that you can put to use immediately. As a seasoned professional of the indie game arena, author Joel Dreskin gives you insight into practical, real-world experiences of marketing numerous successful games and also provides stories of the failures. View it here. An Architectural Approach to Level Design This is one of the first books to integrate architectural and spatial design theory with the field of level design. The book presents architectural techniques and theories for level designers to use in their own work. It connects architecture and level design in different ways that address the practical elements of how designers construct space and the experiential elements of how and why humans interact with this space. Throughout the text, readers learn skills for spatial layout, evoking emotion through gamespaces, and creating better levels through architectural theory. View it here. Learn more and download the ebook by clicking here. Did you know? GameDev.net and CRC Press also recently teamed up to bring GDNet+ Members up to a 20% discount on all CRC Press books. Learn more about this and other benefits here.
Sign in to follow this  
Followers 0
EusKoder

default xna 4.0 gametime don´t works well for physics

3 posts in this topic

Disregard this post - I just re-read and it says you've attempted to disable fixed time stepping. Did you look into the V-Synch as well?

IDK - but it sounds like you may have a problem with the fixed time stepping and/or synch refresh lock in the XNA platform. To maintain a constant draw rate of approximately 60fps, XNA will drop update calls. And perhaps (I'm grasping at straws here) the gameTime doesn't reflect that it's had 10 dropped update calls.

If no one else posts, try setting IsFixedTimeStep to false and GraphicsDeviceManager,SynchronizeWithVerticalRetrace to false as well. See if your results are any different. I suppose it's worth a shot...

-Shadow Edited by ShadowValence
0

Share this post


Link to post
Share on other sites
Hello,
I am developing a game using Visual Studio 2010 and XNA 4.0,
after advancing to some extent with the project (a platform based 2d platformer msdn starter kit) I got to test it on different computers with different hardware (CPU, graphics, etc.) and I found that the speed of movement object of the game is quite different, I implemented the PSK physics msdn that are based on time,

[CODE]
/// <summary>
/// Updates the player's velocity and position based on input, gravity, etc.
/// </summary>
public void ApplyPhysics(GameTime gameTime)
{
float elapsed = (float)gameTime.ElapsedGameTime.TotalSeconds;
Vector2 previousPosition = Position;
// Base velocity is a combination of horizontal movement control and
// acceleration downward due to gravity.
velocity.X += movement * MoveAcceleration * elapsed;
velocity.Y = MathHelper.Clamp(velocity.Y + GravityAcceleration * elapsed, -MaxFallSpeed, MaxFallSpeed);
velocity.Y = DoJump(velocity.Y, gameTime);

// Apply pseudo-drag horizontally.
if (IsOnGround)
velocity.X *= GroundDragFactor;
else
velocity.X *= GroundDragFactor;
//velocity.X *= AirDragFactor;
// Prevent the player from running faster than his top speed.
velocity.X = MathHelper.Clamp(velocity.X, -MaxMoveSpeed, MaxMoveSpeed);
// Apply velocity.
Position += velocity *elapsed;
Position = new Vector2((float)Math.Round(Position.X), (float)Math.Round(Position.Y));

// If the player is now colliding with the level, separate them.
HandleCollisions(gameTime);
// If the collision stopped us from moving, reset the velocity to zero.
if (Position.X == previousPosition.X)
velocity.X = 0;
if (Position.Y == previousPosition.Y)
{
velocity.Y = 0;
jumpTime = 0.0f;
}
}
[/CODE]

tested eg with a PC (PC1) 2.13GHz Intel Core 2 6400 / ATI Radeon HD 4670
and another one: (pc2) 3.00GHz Intel Pentium D / Intel 82945G Express Chipset Family
by displacement difference (moving x axis at supossed (position = velocity * gametime.ElapsedGameTime.TotalSeconds) constant velocity, for example) is 3 seconds in a total of 20 (example: moving pc1 player sprite 6000 pixels in the x-axis at 20 seconds and pc 2 runs the same distance in 17 ).
Tested on a 3rd PC: i72700k / Gigabyte GTX 560 TI
the results are even worse, after some time after starting the game gets like 3 times slower and showing the number of pixels in each frame moved in a debug window in the game (counting updatespersecond with counter variable for updates cuantity and gametime for counting a second show 63fps), it appears as if the number is always constant ( refreshments lose the Update method?).
In this pc if I put the game in fullscreen during the course of the game, the effect of "go slow" is immediate and restore window mode sometimes yield returns to "normal" and sometimes not.
Eventually I began to try a new project to test whether the movement is constant in different pc loading only one sprite and its position value in screen printing.
Occur The same.
I even tried moving a constant amount of pixels explicitly (position + = 5) and different speeds in different pc quantities of pixels moved in x time.
I have the game loop as the default (fixedTimeStep = true ;).
I've also tried turning off and creating another timestep as discussed in different post (eg [url="http://gafferongames.com/game-physics/fix-your-timestep/"]http://gafferongames...-your-timestep/[/url]
but i can´t achieve the desired result, move the same number of pixels in X seconds on different computers with windows.
All pc used for tests use windows 7 enterprise pc1 == x86 the others are x64.

The weirdest thing is that I find information about people describing the same problem and that I wear long nights of searches.

Thanks for your help. Edited by EusKoder
0

Share this post


Link to post
Share on other sites
Problem "solved" the pixel amount difference between computers is because i have a fixedtimestep disabled and one of the tested computers monitor refresh rate is 75hz
If the monitor run at 75hz, in xna with isfixedtimestep=false and vsync actived the game run update 75 times per second.
When the two and more tested pcs are configured at 60hz in all of them works well and at same movement velocity. Edited by EusKoder
0

Share this post


Link to post
Share on other sites
Well that's not really a fix, is it? If a monitor is capable of refreshing 75 times a second it makes little sense to clamp it down to 60Hz because of technical difficulties - you want to take into account the frametime when doing your physics, this will give you more stable physics.
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0